VCOM:VectorWorks:ISDK::GetListBrowserColumnOwnerDrawnType: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 15:05, 12 August 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Gets the list browser column's owner drawn type.


iOwnerDrawnType - input - the list browser item's owner drawn type.

kListBrowserNotOwnerDrawn = 0

kListBrowserSolidRect = 1

kListBrowserDualSolidRect = 2

kListBrowserPatternRect = 3

kListBrowserDualPatternRect = 4

kListBrowserGradientOrImage = 5

kListBrowserBlankOwnerDrawn = 6

kListBrowserTextOwnerDrawn = 7

kListBrowserDashedLine = 8

virtual bool GetListBrowserColumnOwnerDrawnType(
long dialogID,
long componentID,
int iIndex,
int iSubIndex,
int &iOwnerDrawnType)

Parameters

long dialogID No information available.
long componentID No information available.
int iIndex No information available.
int iSubIndex No information available.
int &iOwnerDrawnType No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009