VCOM:VectorWorks:ISDK::GetItemText

From Vectorworks Developer
Revision as of 20:48, 13 August 2008 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Get the text of a layout manager item. This call should only be used inside of an event handler callback function.

NOTE: At least 256 bytes should be allocated for the StringPtr that is passed in. Otherwise, if the user enters a very long string, memory could be overwritten when the string is copied to strCurrentText.

virtual void GetItemText(
long dialogID,
long itemID,
TXString& strCurrentText)

Parameters

long dialogID No information available.
long itemID No information available.
TXString& strCurrentText No information available.

Version

Availability: from Vectorworks 2009