VCOM:VectorWorks:ISDK::GetItemText: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 15:05, 12 August 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Get the text of a layout manager item. This call should only be used inside of an event handler callback function.

NOTE: At least 256 bytes should be allocated for the StringPtr that is passed in. Otherwise, if the user enters a very long string, memory could be overwritten when the string is copied to strCurrentText.

virtual void GetItemText(
long dialogID,
long itemID,
TXString& strCurrentText)

Parameters

long dialogID No information available.
long itemID No information available.
TXString& strCurrentText No information available.

Version

Availability: from Vectorworks 2009