VCOM:VectorWorks:ISDK::GetHostInfo

From Vectorworks Developer
Revision as of 15:05, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

This returns info about the application hosting the external. hostID is set to a constant identifying kMiniCad or kBlueprint defined in MiniCadHookIntf.h. version, majorRev, & minorRev correspond to 5, 0, & 1 in MiniCad 5.0.1. Tha strings returned are the application name and the short version string from the 'vers' resource.

virtual void GetHostInfo(
short& hostID,
Byte& version,
Byte& majorRev,
Byte& minorRev,
TXString& productName,
TXString& productVersion)

Parameters

short& hostID No information available.
Byte& version No information available.
Byte& majorRev No information available.
Byte& minorRev No information available.
TXString& productName No information available.
TXString& productVersion No information available.

Version

Availability: from Vectorworks 2009