VCOM:VectorWorks:ISDK::GetFilePathInUserRoot: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
 
m (1 revision)
 
(No difference)

Latest revision as of 15:05, 12 August 2013

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Get the filename in the given folder class under the User Data root. This function is useful for obtaining the paths of files to save out to.

folderClass: One of the folder type constants defined in FolderSpecifiers.h

fileName: The name of the file

outFilePath: The path to the file under the User Data root.

NOTE: This function is obsolete. Use GetFilePathInUserRootN instead.

virtual bool GetFilePathInUserRoot(
FolderSpecifier folderClass,
const char fileName[255],
char outFilePath[255])

Parameters

FolderSpecifier folderClass No information available.
constchar fileName[255] No information available.
char outFilePath[255] No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009