VCOM:VectorWorks:ISDK::GetCurtainWallPanelInfo: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 25: Line 25:
hWall
hWall
MCObjectHandle
MCObjectHandle
no info.
Handle to the curtain wall object. If this handle is not a handle to a curtain wall, the function will return false.
</line>
</line>
<line>
<line>
inCenterPt
inCenterPt
const [[SDK:WorldPt]]&
const [[SDK:WorldPt]]&
no info.
The center of the object being tested in the space of the wall.
</line>
</line>
<line>
<line>
includeBottomFrame
includeBottomFrame
bool
bool
no info.
Whether to include the bottom frame in the returned information. In the US, this will be true when testing a door and false for a window.  
</line>
</line>
<line>
<line>
outCenterPt
outCenterPt
[[SDK:WorldPt]]&
[[SDK:WorldPt]]&
no info.
The new center point for the object in the wall. This will be the center of the rectangle in which the object is being placed or moved into. The size of the rectangle will be dependent on whether the bottom frame is included, and whether the panel itself is rectangular. If the panel is not rectangular, it will be the center of the largest possible rectangle to be found in the frame. This point will be used to update the horizontal offset in the break record and elevation value of the object.
</line>
</line>
<line>
<line>
outWidth
outWidth
WorldCoord&
WorldCoord&
no info.
The Width of the rectangle to draw the object.
</line>
</line>
<line>
<line>
outHeight
outHeight
WorldCoord&
WorldCoord&
no info.
The Height of the rectangle to draw the object.
</line>
</line>
</lineList>
</lineList>

Latest revision as of 08:30, 19 January 2015

Description

namespace

Member of VCOM:VectorWorks:ISDK

...put some description here...

virtual bool VCOM_CALLTYPE GetCurtainWallPanelInfo(
MCObjectHandle hWall,
const WorldPt& inCenterPt,
bool includeBottomFrame,
WorldPt& outCenterPt,
WorldCoord& outWidth,
WorldCoord& outHeight) = 0;

Parameters

hWall MCObjectHandle Handle to the curtain wall object. If this handle is not a handle to a curtain wall, the function will return false.
inCenterPt const SDK:WorldPt& The center of the object being tested in the space of the wall.
includeBottomFrame bool Whether to include the bottom frame in the returned information. In the US, this will be true when testing a door and false for a window.
outCenterPt SDK:WorldPt& The new center point for the object in the wall. This will be the center of the rectangle in which the object is being placed or moved into. The size of the rectangle will be dependent on whether the bottom frame is included, and whether the panel itself is rectangular. If the panel is not rectangular, it will be the center of the largest possible rectangle to be found in the frame. This point will be used to update the horizontal offset in the break record and elevation value of the object.
outWidth WorldCoord& The Width of the rectangle to draw the object.
outHeight WorldCoord& The Height of the rectangle to draw the object.

Version

Availability: from Vectorworks 2015