VCOM:VectorWorks:ISDK::FontIndexFromName

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

FontIndexFromName allows a file-specific font index to be looked up or assigned based on a font name. If the specified font has been used in the current document, then its index will be returned. If the font has never been used, then a new index will be returned. Once a font index has been assigned, it is guaranteed to remain fixed until the document is closed. The specified font must be present on the current system or the error index (-1) will be returned. If -1 is specified when assigning a font to an object in MiniCAD, the default system font will be used, so it's always legal to pass the result of this function to another SDK call to specify a font index.

virtual short FontIndexFromName(
const TXString& fontName)

Parameters

constTXString& fontName No information available.

Return Value

On error returns: -1

Version

Availability: from Vectorworks 2009