VCOM:VectorWorks:ISDK::FontIndexFromName

From Vectorworks Developer
Revision as of 15:00, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

FontIndexFromName allows a file-specific font index to be looked up or assigned based on a font name. If the specified font has been used in the current document, then its index will be returned. If the font has never been used, then a new index will be returned. Once a font index has been assigned, it is guaranteed to remain fixed until the document is closed. The specified font must be present on the current system or the error index (-1) will be returned. If -1 is specified when assigning a font to an object in MiniCAD, the default system font will be used, so it's always legal to pass the result of this function to another SDK call to specify a font index.

virtual short FontIndexFromName(
const TXString& fontName)

Parameters

constTXString& fontName No information available.

Return Value

On error returns: -1

Version

Availability: from Vectorworks 2009