VCOM:VectorWorks:ISDK::DeleteSavedSetting: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
m (1 revision)
No edit summary
 
Line 9: Line 9:
Member of [[VCOM:VectorWorks:ISDK]]
Member of [[VCOM:VectorWorks:ISDK]]


...put some description here...
Delete all saved settings in the specified category, or delete the specified settings by name only.
</desc>
</desc>


Line 15: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual BooleanVCOM_CALLTYPE DeleteSavedSetting(const TXString& category) = 0;
virtual Boolean VCOM_CALLTYPE DeleteSavedSetting(const TXString& category) = 0;
</funcDef>
<funcDef lang="cpp">
virtual Boolean VCOM_CALLTYPE DeleteSavedSetting(const TXString& category, const TXString& setting) = 0;
</funcDef>
</funcDef>
</def>
</def>
Line 25: Line 28:
category
category
const [[SDK:TXString]]&
const [[SDK:TXString]]&
no info.
Category in which saved settings to be deleted.
</line>
<line>
setting
const [[SDK:TXString]]&
The settings name in the specified category that will be deleted.
</line>
</line>
</lineList>
</lineList>

Latest revision as of 14:51, 19 September 2013

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Delete all saved settings in the specified category, or delete the specified settings by name only.

virtual Boolean VCOM_CALLTYPE DeleteSavedSetting(
const TXString& category) = 0;
virtual Boolean VCOM_CALLTYPE DeleteSavedSetting(
const TXString& category,
const TXString& setting) = 0;

Parameters

category const SDK:TXString& Category in which saved settings to be deleted.
setting const SDK:TXString& The settings name in the specified category that will be deleted.

Version

Availability: from Vectorworks 2014