VCOM:VectorWorks:ISDK::CustomObjectControlPtsCreate

From Vectorworks Developer
Revision as of 15:00, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Creates data storage for Custom Control Points for custom object. If initProc is non-nil then it will be called for each of the controlPt elements. CustomObjects that provide custom Control Points must set the kObjXPropCustomCursorResize Property.

virtual bool CustomObjectControlPtsCreate(
MCObjectHandle inOwnerObj,
int numDataElements,
GS_CustomObjectControlPtsInitProcPtr initProc,
void* env)

Parameters

MCObjectHandle inOwnerObj No information available.
int numDataElements No information available.
GS_CustomObjectControlPtsInitProcPtr initProc No information available.
void* env No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009