VCOM:VectorWorks:ISDK::CreateStaticText

From Vectorworks Developer
Revision as of 19:39, 17 September 2019 by Pchang (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Creates a layout manager static text menu with the given itemID.

widthInCharacters is only used for multiline static texts. For single line static text set this field to -1 and the appropriate width will be calculated.


Event handling:

no event handling for static text.

virtual void CreateStaticText(
long dialogID,
long itemID,
const TXString& text,
short widthInCharacters)

Parameters

long dialogID No information available.
long itemID No information available.
constTXString& text No information available.
short widthInCharacters Width in the number of the width of the 'a' character.

Version

Availability: from Vectorworks 2009