VCOM:VectorWorks:ISDK::CreateEditText

From Vectorworks Developer
Revision as of 15:00, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Creates a layout manager edit box with the given itemID. The widthInCharacters specifies the aproximate number of characters that will be visible in the edit box. The edit text is limited to 255 characters

Event handling:

an event is generated everytime a key is hit in the edit text, the value of the data field is undefined

virtual void CreateEditText(
long dialogID,
long itemID,
const TXString& defaultText,
short widthInCharacters,
short heightInLines = 1)

Parameters

long dialogID No information available.
long itemID No information available.
constTXString& defaultText No information available.
short widthInCharacters No information available.
shortheightInLines= 1 No information available.

Version

Availability: from Vectorworks 2009