VCOM:VectorWorks:ISDK::CreateControl

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Creates the control specified by controlKind. The name and data parameter are general input parameters for the different control types. See MiniCadCallBacks.X.h for the complete list of indexed controls.

virtual void CreateControl(
long dialogID,
long itemID,
long controlKind,
const TXString& name,
long data)

Parameters

long dialogID No information available.
long itemID No information available.
long controlKind No information available.
constTXString& name No information available.
long data No information available.

Version

Availability: from Vectorworks 2009