VCOM:VectorWorks:ISDK::CallPluginLibrary

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Call an VectorScript routine.

virtual bool CallPluginLibrary(
const TXString& routineName,
void* argumentTable,
long status)

Parameters

constTXString& routineName The name of the VectorScript to be called.
void* argumentTable A pointer to the array of argument values to the library routine. See PluginLibraryArgTable in MiniCadCallBacks.h.
long status Unused. Use 0.

Return Value

On error returns: false

Example

PluginLibraryArgTable    argTable;
argTable.args[0].argType          = kIntegerArgType;
argTable.args[0].intValue         = 11;
argTable.args[1].argType          = kStringArgType;
TXString("hello string").CopyInto( argTable.args[1].strValue );
argTable.functionResult.argType   = kBooleanArgType;
argTable.functionResult.boolValue = false;
gSDK->CallPluginLibrary( "MyRoutine", & argTable, 0 );

Version

Availability: from Vectorworks 2009