VCOM:VectorWorks:ISDK::AlignLeftEdge

From Vectorworks Developer
Revision as of 14:59, 12 August 2013 by Root (talk | contribs) (1 revision)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Sets the leftID for the srcItem. The leftID can be any number. All items with the same leftID will be aligned along their left edge.


alignMode = eResize = 0 resize the item to align the edge

alignMode = eShift = 1 shift the item to align the edge

virtual bool AlignLeftEdge(
long dialogID,
long srcItemID,
short leftID,
short alignMode = 1)

Parameters

long dialogID No information available.
long srcItemID No information available.
short leftID No information available.
shortalignMode= 1 No information available.

Return Value

On error returns: false

Version

Availability: from Vectorworks 2009