VCOM:VectorWorks:ISDK::AlertQuestionDefault

From Vectorworks Developer
Revision as of 11:32, 19 February 2014 by Maarten (talk | contribs) (Added the same info as VCOM:VectorWorks:ISDK::AlertQuestion)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks

Member of VCOM:VectorWorks:ISDK

Displays a dialog that alerts the user to a condition or situation that requires the user's decision and input before preceeding, such as an impending action with potentially destructive or irreversible consequencies. Specify a category and an item to show an optional 'Always do the selected action' checkbox.

virtual shortVCOM_CALLTYPE AlertQuestionDefault(
const TXString& question,
const TXString& advice = "",
short defaultButton = 0,
const TXString& OKOverrideText = "",
const TXString& CancelOverrideText = "",
const TXString& customButtonAText = "",
const TXString& customButtonBText = "",
const TXString& category = "",
const TXString& item = "",
const TXString& checkboxOverrideText = "",
short defaultAnswer = -1) = 0;

Parameters

question const SDK:TXString& Question text that appears in the dialog.
advice const SDK:TXString& Advice text that appears in the dialog.
defaultButton short Default button that is selected in the dialog.
OKOverrideText const SDK:TXString& Text that should appear on the OK button.
CancelOverrideText const SDK:TXString& Text that should appear on the CANCEL button.
customButtonAText const SDK:TXString& First additional button text. If empty no button appears.
customButtonBText const SDK:TXString& Second additional button text. If empty no button appears.
category const SDK:TXString& Category for the saved settings that the answer will be stored.
item const SDK:TXString& Item for the category of the saved settings that the answer will be stored.
checkboxOverrideText const SDK:TXString& Override text for the check button.
defaultAnswer short no info.

Version

Availability: from Vectorworks 2010