VCOM:VectorWorks:IFCLib:IIFCSupport::WS FillCOBieFixedWorksheets

From Vectorworks Developer
Revision as of 08:23, 13 April 2018 by KGoranov (talk | contribs)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Automatically fills a worksheet with COBie data, provided the correct worksheet handle is given. See Remarks for further information.

VCOMError WS_FillCOBieFixedWorksheets(
MCObjectHandle worksheet,
bool bIsRolledUp);

Parameters

worksheet MCObjectHandle Handle to worksheet
bIsRolledUp bool Boolean not used.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

Remarks

This function can fill 10 designated worksheets with COBie data. In order to get an accurate COBie worksheet a correct handle to a preformatted worksheet must be provided. It can be called for the following preformatted reports:


  • COBieContact Worksheet
  • COBieContact Help Worksheet
  • COBieFacility Worksheet
  • COBieFacility Help Worksheet
  • COBieFloor Worksheet
  • COBieFloor Help Worksheet
  • COBieAttribute Worksheet
  • COBieAttribute Help Worksheet
  • COBieSystem Worksheet
  • COBieSystem Help Worksheet


They can be found in the Vectorworks default content in the following location: Defaults >> Reports_Schedules >> COBie.vwx .

In order to fully understand what COBie is and how the COBie worksheet are structured, please follow the links provided in the See Also section.


Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2018.

See Also

COBie

COBie Responsibility Matrix

[https://en.wikipedia.org/wiki/COBie COBie] [http://projects.buildingsmartalliance.org/files/?artifact_id=4093 COBie Responsibility Matrix]