VCOM:VectorWorks:IFCLib:IIFCSupport::WS FillCOBieFixedWorksheets: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 85: Line 85:
<seeAlso>
<seeAlso>
[http://projects.buildingsmartalliance.org/files/?artifact_id=4093 COBie Responsibility Matrix]
[http://projects.buildingsmartalliance.org/files/?artifact_id=4093 COBie Responsibility Matrix]
[[https://en.wikipedia.org/wiki/COBie|COBie]]
[https://en.wikipedia.org/wiki/COBie COBie]
</seeAlso>
</seeAlso>



Revision as of 14:54, 5 April 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Fills a worksheet with COBie data.

VCOMError WS_FillCOBieFixedWorksheets(
MCObjectHandle worksheet,
bool bIsRolledUp);

Parameters

worksheet MCObjectHandle Handle to worksheet
bIsRolledUp bool Boolean not used.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

Remarks

In order to fully understand what is COBie and what are the COBie worksheets please follow the links provided in the See Also section.

This function can fill 10 designated worksheets with COBie data. In order to get an accurate COBie data in them, the correct handle to the correct worksheet must be provided. This function only works with the following Preformatted worksheets:

COBieContact Worksheet COBieContact Help Worksheet COBieFacility Worksheet COBieFacility Help Worksheet COBieFloor Worksheet COBieFloor Help Worksheet COBieAttribute Worksheet COBieAttribute Help Worksheet COBieSystem Worksheet COBieSystem Help Worksheet

They can be found in the Vectorworks default content in the following location: Defaults >> Reports_Schedules >> COBie.vwx .

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2018.

See Also

COBie Responsibility Matrix

COBie

[http://projects.buildingsmartalliance.org/files/?artifact_id=4093 COBie Responsibility Matrix] [https://en.wikipedia.org/wiki/COBie COBie]