VCOM:VectorWorks:IFCLib:IIFCSupport::WS FillCOBieFixedWorksheets: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(9 intermediate revisions by one other user not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


Fills a worksheet with COBie data.
Automatically fills a worksheet with COBie data, provided the correct worksheet handle is given. See Remarks for further information.
</desc>
</desc>


Line 30: Line 30:
bIsRolledUp
bIsRolledUp
bool
bool
Boolean not used.
Parameter is not used. Set to True.
</line>
</line>
</lineList>
</lineList>
Line 58: Line 58:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
In order to fully understand what is COBie and what are the COBie worksheets please follow the links provided in the See Also section.
This function can fill 10 designated worksheets with COBie data. In order to get an accurate COBie worksheet a correct handle to a preformatted worksheet must be provided. It can be called for the following preformatted reports:


This function can fill 10 designated worksheets with COBie data. In order to get an accurate COBie data in them, the correct handle to the correct worksheet must be provided. This function only works with the following Preformatted worksheets:


* COBieContact Worksheet
* COBieContact Worksheet
Line 73: Line 72:
* COBieSystem Help Worksheet
* COBieSystem Help Worksheet


They can be found in the Vectorworks default content in the following location: Defaults >> Reports_Schedules >> COBie.vwx .   
 
The worksheets can be found in the Vectorworks default content in the following location: Defaults >> Reports_Schedules >> COBie.vwx .
 
In order to fully understand what COBie is and how the COBie worksheet are structured, please follow the links:  
 
[https://en.wikipedia.org/wiki/COBie COBie]
 
[http://projects.buildingsmartalliance.org/files/?artifact_id=4093 COBie Responsibility Matrix]




Line 85: Line 91:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[http://projects.buildingsmartalliance.org/files/?artifact_id=4093 COBie Responsibility Matrix]
[https://en.wikipedia.org/wiki/COBie COBie]
</seeAlso>
</seeAlso>



Latest revision as of 15:19, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Automatically fills a worksheet with COBie data, provided the correct worksheet handle is given. See Remarks for further information.

VCOMError WS_FillCOBieFixedWorksheets(
MCObjectHandle worksheet,
bool bIsRolledUp);

Parameters

worksheet MCObjectHandle Handle to worksheet
bIsRolledUp bool Parameter is not used. Set to True.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

Remarks

This function can fill 10 designated worksheets with COBie data. In order to get an accurate COBie worksheet a correct handle to a preformatted worksheet must be provided. It can be called for the following preformatted reports:


  • COBieContact Worksheet
  • COBieContact Help Worksheet
  • COBieFacility Worksheet
  • COBieFacility Help Worksheet
  • COBieFloor Worksheet
  • COBieFloor Help Worksheet
  • COBieAttribute Worksheet
  • COBieAttribute Help Worksheet
  • COBieSystem Worksheet
  • COBieSystem Help Worksheet


The worksheets can be found in the Vectorworks default content in the following location: Defaults >> Reports_Schedules >> COBie.vwx .

In order to fully understand what COBie is and how the COBie worksheet are structured, please follow the links:

COBie

COBie Responsibility Matrix


Use this function via global pointer gIFC.

Version

Available from: Vectorworks 2018.