VCOM:VectorWorks:IFCLib:IIFCSupport::ShowPickIFCTypeDlg2

From Vectorworks Developer
Revision as of 14:59, 19 June 2018 by NBeshevliev (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Displays a dialog from which the user can choose which IFC type to attach to object.

VCOMError ShowPickIFCTypeDlg2(
TXString& inOutIfcObjName);

Parameters

inOutIfcObjName TXString As input parameter the value is set to the "Filter List" field on the dialog. As out parameter it is the chosen IFC Type from the dialog.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_False Routine failed.
kVCOMError_NoError The function succeeded. No Error!

Remarks

Use this function via global pointer gIFC.

Select IFC Object dialog with input string - "IfcColumn". Image from Vectorworks 2018

Version

Available from: VectorWorks 2017

See Also

VCOM:VectorWorks:IFCLib:IIFCSupport::ShowPickIFCTypeDlg

[[VCOM:VectorWorks:IFCLib:IIFCSupport::ShowPickIFCTypeDlg]]