VCOM:VectorWorks:IFCLib:IIFCSupport::ShowPickIFCTypeDlg2: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 25: Line 25:
inOutIfcObjName
inOutIfcObjName
TXString
TXString
If there is input string it is going to be set to the "Filter List" on the dialog. The out value is the chosen IFC Type from the dialog.
As input parameter the value is set to the "Filter List" field on the dialog. As out parameter it is the chosen IFC Type from the dialog.
</line>
</line>
</lineList>
</lineList>
Line 65: Line 65:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: VectorWorks 17
Available from: VectorWorks 2017
</version>
</version>



Revision as of 11:59, 16 February 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Displays a dialog from which the user can choose which IFC type to attach to object.

VCOMError ShowPickIFCTypeDlg2(
TXString& inOutIfcObjName);

Parameters

inOutIfcObjName TXString As input parameter the value is set to the "Filter List" field on the dialog. As out parameter it is the chosen IFC Type from the dialog.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_False Routine failed.
kVCOMError_NoError The function succeeded. No Error!

Remarks

Use this function via global pointer gIFC.

Select IFC Object dialog with input string - "IfcColumn". Image from Vectorworks 2018

Version

Available from: VectorWorks 2017

See Also

VCOM:VectorWorks:Extension:IIFCSupport::ShowPickIFCTypeDlg

[[VCOM:VectorWorks:Extension:IIFCSupport::ShowPickIFCTypeDlg]]