VCOM:VectorWorks:IFCLib:IIFCSupport::ShowPickIFCTypeDlg2: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
(Created page with "{{LocationMain|category=LocationVCOM|specific=}} __TOC__ <vwDoc> ----------------------------------------------------------------------------------------------------------- <...")
 
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


...put some description here...
Displays a dialog from which the user can choose which IFC type to attach to object.
</desc>
</desc>


Line 25: Line 25:
inOutIfcObjName
inOutIfcObjName
TXString
TXString
no info.
If there is input string it is going to be set to the "Filter List" on the dialog. The out value is the chosen IFC Type from the dialog.
</line>
</line>
</lineList>
</lineList>
Line 45: Line 45:
</line>
</line>
<line>
<line>
kVCOMError_Failed
kVCOMError_False
Routine failed.
Routine failed.
</line>
<line>
kVCOMError_NoError
The function succeeded. No Error!
</line>
</line>
</lineList>
</lineList>
Line 54: Line 58:
<remark>
<remark>
Use this function via global pointer gIFC.  
Use this function via global pointer gIFC.  
[[File:IFCTypeDlg2.png|527x600px|thumbnail|center|Select IFC Object dialog with input string - "IfcColumn". Image from Vectorworks 2018]]
</remark>  
</remark>  


Line 62: Line 68:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[VCOM:VectorWorks:Extension:IIFCSupport::ShowPickIFCTypeDlg]]
</seeAlso>
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: VectorWorks 17
</version>
</version>



Revision as of 11:54, 16 February 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Displays a dialog from which the user can choose which IFC type to attach to object.

VCOMError ShowPickIFCTypeDlg2(
TXString& inOutIfcObjName);

Parameters

inOutIfcObjName TXString If there is input string it is going to be set to the "Filter List" on the dialog. The out value is the chosen IFC Type from the dialog.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_False Routine failed.
kVCOMError_NoError The function succeeded. No Error!

Remarks

Use this function via global pointer gIFC.

Select IFC Object dialog with input string - "IfcColumn". Image from Vectorworks 2018

Version

Available from: VectorWorks 17

See Also

VCOM:VectorWorks:Extension:IIFCSupport::ShowPickIFCTypeDlg

[[VCOM:VectorWorks:Extension:IIFCSupport::ShowPickIFCTypeDlg]]