VCOM:VectorWorks:IFCLib:IIFCSupport::ShowPickIFCTypeDlg2: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(2 intermediate revisions by one other user not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


Displays a dialog from which the user can choose which IFC type to attach to object.
Displays a dialog from which the user can choose which IFC type to attach to object.
Line 60: Line 60:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[VCOM:VectorWorks:Extension:IIFCSupport::ShowPickIFCTypeDlg]]
[[VCOM:VectorWorks:IFCLib:IIFCSupport::ShowPickIFCTypeDlg]]
</seeAlso>
</seeAlso>


Line 70: Line 70:
</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|ShowPickIFCTypeDlg2]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|ShowPickIFCTypeDlg2]]

Latest revision as of 14:59, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Displays a dialog from which the user can choose which IFC type to attach to object.

VCOMError ShowPickIFCTypeDlg2(
TXString& inOutIfcObjName);

Parameters

inOutIfcObjName TXString As input parameter the value is set to the "Filter List" field on the dialog. As out parameter it is the chosen IFC Type from the dialog.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_False Routine failed.
kVCOMError_NoError The function succeeded. No Error!

Remarks

Use this function via global pointer gIFC.

Select IFC Object dialog with input string - "IfcColumn". Image from Vectorworks 2018

Version

Available from: VectorWorks 2017

See Also

VCOM:VectorWorks:IFCLib:IIFCSupport::ShowPickIFCTypeDlg

[[VCOM:VectorWorks:IFCLib:IIFCSupport::ShowPickIFCTypeDlg]]