VCOM:VectorWorks:IFCLib:IIFCSupport::ShowPickIFCTypeDlg

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Displays a dialog from which the user can choose which IFC type to attach to object.

VCOMError ShowPickIFCTypeDlg(
TXString& outIfcObjName);

Parameters

outIfcObjName TXString The chosen value from the dialog.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_False The function failed.
kVCOMError_NoError The function succeeded. No Error!

Remarks

Use this function via global pointer gIFC.

Select IFC Object dialog. Image from Vectorworks 2018

Version

Available from: VectorWorks 12

See Also

VCOM:VectorWorks:Extension:IIFCSupport::ShowPickIFCTypeDlg2

[[VCOM:VectorWorks:Extension:IIFCSupport::ShowPickIFCTypeDlg2]]