VCOM:VectorWorks:IFCLib:IIFCSupport::ShowPickIFCTypeDlg: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 10: Line 10:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


...put some description here...
Displays a dialog from which you can choose which IFC type to attach to object.
</desc>
</desc>


Line 16: Line 16:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual VCOMErrorVCOM_CALLTYPE ShowPickIFCTypeDlg(TXString& outIfcObjName) = 0;
VCOMError ShowPickIFCTypeDlg(TXString& outIfcObjName);
</funcDef>
</funcDef>
</def>
</def>
Line 26: Line 26:
outIfcObjName
outIfcObjName
[[SDK:TXString]]&
[[SDK:TXString]]&
no info.
The chosen value from the dialog.
</line>
</line>
</lineList>
</lineList>
Line 38: Line 38:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
kVCOMError_NotInitialized
kVCOMError_False
Bad VCOM instance used to call the fuction.
The function failed.
</line>
</line>
<line>
<line>
kVCOMError_Failed
kVCOMError_NoError
Routine failed.
The function succeeded. No Error!
</line>
</line>
</lineList>
</lineList>
Line 52: Line 52:
Use this function via global pointer gIFC.  
Use this function via global pointer gIFC.  
</remark>
</remark>
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<sample>
Line 63: Line 62:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: VectorWorks 12
</version>
</version>



Revision as of 15:39, 16 January 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Displays a dialog from which you can choose which IFC type to attach to object.

VCOMError ShowPickIFCTypeDlg(
TXString& outIfcObjName);

Parameters

outIfcObjName SDK:TXString& The chosen value from the dialog.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_False The function failed.
kVCOMError_NoError The function succeeded. No Error!

Remarks

Use this function via global pointer gIFC.

Version

Available from: VectorWorks 12