VCOM:VectorWorks:IFCLib:IIFCSupport::ShowPickIFCTypeDlg: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
(10 intermediate revisions by 3 users not shown)
Line 1: Line 1:
{{LocationMain|category=LocationVCOM|specific=}}
{{LocationMain|category=LocationVCOM|specific=}}
__TOC__
__TOC__
<vwDoc>
<vwDoc>
Line 8: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Displays a dialog from which the user can choose which IFC type to attach to object.
</desc>
</desc>


Line 16: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual VCOMErrorVCOM_CALLTYPE ShowPickIFCTypeDlg(TXString& outIfcObjName) = 0;
VCOMError ShowPickIFCTypeDlg(TXString& outIfcObjName);
</funcDef>
</funcDef>
</def>
</def>
Line 25: Line 24:
<line>
<line>
outIfcObjName
outIfcObjName
[[SDK:TXString]]&
TXString
no info.
The chosen value from the dialog.
</line>
</line>
</lineList>
</lineList>
Line 38: Line 37:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
kVCOMError_NotInitialized
kVCOMError_False
Bad VCOM instance used to call the fuction.
The function failed.
</line>
</line>
<line>
<line>
kVCOMError_Failed
kVCOMError_NoError
Routine failed.
The function succeeded. No Error!
</line>
</line>
</lineList>
</lineList>
Line 50: Line 49:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
Use this function via global pointer gIFC.
[[File:PickIFCTypeDlg.png|527x600px|thumbnail|center|Select IFC Object dialog. Image from Vectorworks 2018]]
</remark>
</remark>
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<sample>
<sample>
Line 58: Line 59:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[VCOM:VectorWorks:IFCLib:IIFCSupport::ShowPickIFCTypeDlg2]]
</seeAlso>
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: VectorWorks 12
</version>
</version>



Latest revision as of 14:59, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Displays a dialog from which the user can choose which IFC type to attach to object.

VCOMError ShowPickIFCTypeDlg(
TXString& outIfcObjName);

Parameters

outIfcObjName TXString The chosen value from the dialog.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_False The function failed.
kVCOMError_NoError The function succeeded. No Error!

Remarks

Use this function via global pointer gIFC.

Select IFC Object dialog. Image from Vectorworks 2018

Version

Available from: VectorWorks 12

See Also

VCOM:VectorWorks:IFCLib:IIFCSupport::ShowPickIFCTypeDlg2

[[VCOM:VectorWorks:IFCLib:IIFCSupport::ShowPickIFCTypeDlg2]]