VCOM:VectorWorks:IFCLib:IIFCSupport::ShowPickIFCTypeDlg: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 24: Line 24:
<line>
<line>
outIfcObjName
outIfcObjName
[[SDK:TXString]]&
TXString
The chosen value from the dialog.
The chosen value from the dialog.
</line>
</line>

Revision as of 11:51, 23 January 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Displays a dialog from which you can choose which IFC type to attach to object.

VCOMError ShowPickIFCTypeDlg(
TXString& outIfcObjName);

Parameters

outIfcObjName TXString The chosen value from the dialog.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_False The function failed.
kVCOMError_NoError The function succeeded. No Error!

Remarks

Use this function via global pointer gIFC.

Version

Available from: VectorWorks 12