VCOM:VectorWorks:IFCLib:IIFCSupport::ShowObjectIFCDataEditDlg

From Vectorworks Developer
Revision as of 12:03, 19 January 2018 by KGoranov (talk | contribs)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Displays a dialog from which you can edit object's IFC data.

VCOMError ShowObjectIFCDataEditDlg(
MCObjectHandle hObject,
const TXString& strIfcObjName,
bool bCreateData,
bool bAllowTypeChange = true,
bool bDisableIFCEntity = false,
bool bDoUndo = true)

Parameters

hObject MCObjectHandle Handle to the object.
strIfcObjName const SDK:TXString& IFC Entity.
bCreateData bool Obsolete flag. Set it to true.
bAllowTypeChange bool Flag that determines whether the IFC type can be changed via the Select button.
bDisableIFCEntity bool Flag that determines whether it is allowed to create an IFC entity from the selected object via the Create IFC Entity checkbox. Parameter available from: Vectorworks 19.
bDoUndo bool Enable/Disable undo. Parameter available from: Vectorworks 19.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.