VCOM:VectorWorks:IFCLib:IIFCSupport::ShowObjectIFCDataEditDlg: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 46: Line 46:
bDisableIFCEntity
bDisableIFCEntity
bool
bool
Flag that determines whether it is allowed to create an IFC entity from the selected object via the Create IFC Entity checkbox. Parameter available from: Vectorworks 2013.
Flag that determines whether it is allowed to create an IFC entity from the selected object via the Create IFC Entity checkbox. Parameter available from: Vectorworks 2014.
</line>
</line>
<line>
<line>
bDoUndo
bDoUndo
bool
bool
Enable/Disable undo. Parameter available from: Vectorworks 2013.
Enable/Disable undo. Parameter available from: Vectorworks 2014.
</line>
</line>
</lineList>
</lineList>

Revision as of 12:06, 19 January 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Displays a dialog from which you can edit object's IFC data.

VCOMError ShowObjectIFCDataEditDlg(
MCObjectHandle hObject,
const TXString& strIfcObjName,
bool bCreateData,
bool bAllowTypeChange = true,
bool bDisableIFCEntity = false,
bool bDoUndo = true)

Parameters

hObject MCObjectHandle Handle to the object.
strIfcObjName const SDK:TXString& IFC Entity.
bCreateData bool Obsolete flag. Set it to true.
bAllowTypeChange bool Flag that determines whether the IFC type can be changed via the Select button.
bDisableIFCEntity bool Flag that determines whether it is allowed to create an IFC entity from the selected object via the Create IFC Entity checkbox. Parameter available from: Vectorworks 2014.
bDoUndo bool Enable/Disable undo. Parameter available from: Vectorworks 2014.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.