VCOM:VectorWorks:IFCLib:IIFCSupport::ShowObjectIFCDataEditDlg: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 16: Line 16:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
VCOMError ShowObjectIFCDataEditDlg(MCObjectHandle hObject, const TXString& strIfcObjName, bool bCreateData, bool bAllowTypeChange = true)
VCOMError ShowObjectIFCDataEditDlg(MCObjectHandle hObject, const TXString& strIfcObjName, bool bCreateData, bool bAllowTypeChange = true, bool bDisableIFCEntity = false, bool bDoUndo = true)
</funcDef>
</funcDef>
</def>
</def>

Revision as of 10:32, 19 January 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Displays a dialog from which you can edit the object's IFC data.

VCOMError ShowObjectIFCDataEditDlg(
MCObjectHandle hObject,
const TXString& strIfcObjName,
bool bCreateData,
bool bAllowTypeChange = true,
bool bDisableIFCEntity = false,
bool bDoUndo = true)

Parameters

hObject MCObjectHandle Handle to the object.
strIfcObjName const SDK:TXString& IFC Entity.
bCreateData bool Obsolete flag.
bAllowTypeChange bool Flag that determines whether the IFC type can be changed from the via the Select button. By default set to true.
bDisableIFCEntity bool Flag that determines whether it is allowed to create and IFC entity from the selected object via the Create IFC Entity checkbox. By default set to false.
bDoUndo bool Undo Flag. By default set to true.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.

Remarks

Use this function via global pointer gIFC.