VCOM:VectorWorks:IFCLib:IIFCSupport::ShowObjectIFCDataEditDlg: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 10: Line 10:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


...put some description here...
Displays a dialog from which you can edit the object's IFC data.
</desc>
</desc>


Line 26: Line 26:
hObject
hObject
MCObjectHandle
MCObjectHandle
no info.
Handle to the object.
</line>
</line>
<line>
<line>
strIfcObjName
strIfcObjName
const [[SDK:TXString]]&
const [[SDK:TXString]]&
no info.
IFC Entity.
</line>
</line>
<line>
<line>
bCreateData
bCreateData
bool
bool
no info.
Obsolete flag.
</line>
</line>
<line>
<line>
bAllowTypeChange
bAllowTypeChange
bool
bool
no info.
Flag that determines whether the IFC type can be changed from the via the Select button. By default set to true.
</line>
<line>
bDisableIFCEntity
bool
Flag that determines whether it is allowed to create and IFC entity from the selected object via the Create IFC Entity checkbox. By default set to false.
</line>
<line>
bDoUndo
bool
Undo Flag. By default set to true.  
</line>
</line>
</lineList>
</lineList>
Line 59: Line 69:
kVCOMError_Failed
kVCOMError_Failed
Routine failed.
Routine failed.
</line>
<line>
kVCOMError_NoError
Routine succeeded.
</line>
</line>
</lineList>
</lineList>

Revision as of 10:30, 19 January 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Displays a dialog from which you can edit the object's IFC data.

VCOMError ShowObjectIFCDataEditDlg(
MCObjectHandle hObject,
const TXString& strIfcObjName,
bool bCreateData,
bool bAllowTypeChange = true)

Parameters

hObject MCObjectHandle Handle to the object.
strIfcObjName const SDK:TXString& IFC Entity.
bCreateData bool Obsolete flag.
bAllowTypeChange bool Flag that determines whether the IFC type can be changed from the via the Select button. By default set to true.
bDisableIFCEntity bool Flag that determines whether it is allowed to create and IFC entity from the selected object via the Create IFC Entity checkbox. By default set to false.
bDoUndo bool Undo Flag. By default set to true.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.

Remarks

Use this function via global pointer gIFC.