VCOM:VectorWorks:IFCLib:IIFCSupport::ShowObjectIFCDataEditDlg: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


Displays a dialog from which the user can edit object's IFC data.
Displays a dialog from which the user can edit object's IFC data.

Latest revision as of 14:59, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Displays a dialog from which the user can edit object's IFC data.

VCOMError ShowObjectIFCDataEditDlg(
MCObjectHandle hObject,
const TXString& strIfcObjName,
bool bCreateData,
bool bAllowTypeChange = true,
bool bDisableIFCEntity = false,
bool bDoUndo = true);

Parameters

hObject MCObjectHandle Handle to the object.
strIfcObjName TXString IFC Entity.
bCreateData bool Obsolete flag. Set it to true.
bAllowTypeChange bool Flag that determines whether the IFC type can be changed via the Select button.
bDisableIFCEntity bool Flag that determines whether it is allowed to create an IFC entity from the selected object via the Create IFC Entity checkbox. Parameter available from: Vectorworks 2014.
bDoUndo bool Enable/Disable undo. Parameter available from: Vectorworks 2014.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.

Remarks

Use this function via global pointer gIFC.

IFC Data dialog. The example is from object with attached IfcSlab Entity. Image from Vectorworks 2018

Version

Available from: Vectorworks 12.

See Also

VCOM:VectorWorks:IFCLib:IIFCSupport::ShowIFCDataForSelection

[[VCOM:VectorWorks:IFCLib:IIFCSupport::ShowIFCDataForSelection]]