VCOM:VectorWorks:IFCLib:IIFCSupport::ShowObjectIFCDataEditDlg: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(11 intermediate revisions by 3 users not shown)
Line 1: Line 1:
{{LocationMain|category=LocationVCOM|specific=}}
{{LocationMain|category=LocationVCOM|specific=}}
__TOC__
__TOC__
<vwDoc>
<vwDoc>
Line 8: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


Displays a dialog from which you can edit object's IFC data.
Displays a dialog from which the user can edit object's IFC data.
</desc>
</desc>


Line 16: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
VCOMError ShowObjectIFCDataEditDlg(MCObjectHandle hObject, const TXString& strIfcObjName, bool bCreateData, bool bAllowTypeChange = true, bool bDisableIFCEntity = false, bool bDoUndo = true)
VCOMError ShowObjectIFCDataEditDlg(MCObjectHandle hObject, const TXString& strIfcObjName, bool bCreateData, bool bAllowTypeChange = true, bool bDisableIFCEntity = false, bool bDoUndo = true);
</funcDef>
</funcDef>
</def>
</def>
Line 30: Line 29:
<line>
<line>
strIfcObjName
strIfcObjName
const [[SDK:TXString]]&
TXString
IFC Entity.
IFC Entity.
</line>
</line>
Line 46: Line 45:
bDisableIFCEntity
bDisableIFCEntity
bool
bool
Flag that determines whether it is allowed to create an IFC entity from the selected object via the Create IFC Entity checkbox. Parameter available from: Vectorworks 19.
Flag that determines whether it is allowed to create an IFC entity from the selected object via the Create IFC Entity checkbox. Parameter available from: Vectorworks 2014.
</line>
</line>
<line>
<line>
bDoUndo
bDoUndo
bool
bool
Enable/Disable undo. Parameter available from: Vectorworks 19.
Enable/Disable undo. Parameter available from: Vectorworks 2014.
</line>
</line>
</lineList>
</lineList>
Line 80: Line 79:
<remark>
<remark>
Use this function via global pointer gIFC.  
Use this function via global pointer gIFC.  
[[File:IFCDataDlg.png|527x600px|thumbnail|center|IFC Data dialog. The example is from object with attached IfcSlab Entity. Image from Vectorworks 2018]]
</remark>
</remark>


Line 88: Line 89:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[VCOM:VectorWorks:IFCLib:IIFCSupport::ShowIFCDataForSelection]]
</seeAlso>
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 8.
Available from: Vectorworks 12.
</version>
</version>


</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|ShowObjectIFCDataEditDlg]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|ShowObjectIFCDataEditDlg]]

Latest revision as of 14:59, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Displays a dialog from which the user can edit object's IFC data.

VCOMError ShowObjectIFCDataEditDlg(
MCObjectHandle hObject,
const TXString& strIfcObjName,
bool bCreateData,
bool bAllowTypeChange = true,
bool bDisableIFCEntity = false,
bool bDoUndo = true);

Parameters

hObject MCObjectHandle Handle to the object.
strIfcObjName TXString IFC Entity.
bCreateData bool Obsolete flag. Set it to true.
bAllowTypeChange bool Flag that determines whether the IFC type can be changed via the Select button.
bDisableIFCEntity bool Flag that determines whether it is allowed to create an IFC entity from the selected object via the Create IFC Entity checkbox. Parameter available from: Vectorworks 2014.
bDoUndo bool Enable/Disable undo. Parameter available from: Vectorworks 2014.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.

Remarks

Use this function via global pointer gIFC.

IFC Data dialog. The example is from object with attached IfcSlab Entity. Image from Vectorworks 2018

Version

Available from: Vectorworks 12.

See Also

VCOM:VectorWorks:IFCLib:IIFCSupport::ShowIFCDataForSelection

[[VCOM:VectorWorks:IFCLib:IIFCSupport::ShowIFCDataForSelection]]