VCOM:VectorWorks:IFCLib:IIFCSupport::ShowObjectIFCDataEditDlg: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 41: Line 41:
bAllowTypeChange
bAllowTypeChange
bool
bool
Flag that determines whether the IFC type can be changed from the via the Select button. By default set to true.
Flag that determines whether the IFC type can be changed via the Select button.
</line>
</line>
<line>
<line>
bDisableIFCEntity
bDisableIFCEntity
bool
bool
Flag that determines whether it is allowed to create and IFC entity from the selected object via the Create IFC Entity checkbox. By default set to false.  
Flag that determines whether it is allowed to create an IFC entity from the selected object via the Create IFC Entity checkbox.
</line>
</line>
<line>
<line>
bDoUndo
bDoUndo
bool
bool
Undo Flag. By default set to true.  
Undo Flag.
</line>
</line>
</lineList>
</lineList>

Revision as of 10:33, 19 January 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Displays a dialog from which you can edit the object's IFC data.

VCOMError ShowObjectIFCDataEditDlg(
MCObjectHandle hObject,
const TXString& strIfcObjName,
bool bCreateData,
bool bAllowTypeChange = true,
bool bDisableIFCEntity = false,
bool bDoUndo = true)

Parameters

hObject MCObjectHandle Handle to the object.
strIfcObjName const SDK:TXString& IFC Entity.
bCreateData bool Obsolete flag.
bAllowTypeChange bool Flag that determines whether the IFC type can be changed via the Select button.
bDisableIFCEntity bool Flag that determines whether it is allowed to create an IFC entity from the selected object via the Create IFC Entity checkbox.
bDoUndo bool Undo Flag.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.

Remarks

Use this function via global pointer gIFC.