VCOM:VectorWorks:IFCLib:IIFCSupport::ShowManagePsetsDlg

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Shows the Manage Custom Property Sets dialog. From it users can select document Record Formats to be used as custom IFC Property Sets.

VCOMError ShowManagePsetsDlg( );

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Error creating thumbnail: Incomplete GD library configuration: Missing function imagecreatefromjpeg
Manage Custom Property Sets dialog. Image from Vectorworks 2018

Version

Available from: Vectorworks 2018.