VCOM:VectorWorks:IFCLib:IIFCSupport::ShowManagePsetsDlg

From Vectorworks Developer
Revision as of 11:52, 16 February 2018 by KGoranov (talk | contribs)
Jump to navigation Jump to search

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Shows the Manage Custom Property Sets dialog. From it users can select document Record Formats to be used as custom IFC Property Sets.

VCOMError ShowManagePsetsDlg( );

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Error creating thumbnail: Incomplete GD library configuration: Missing function imagecreatefromjpeg
Manage Custom Property Sets dialog. Image from Vectorworks 2018

Version

Function available since Vectorworks 2018.