VCOM:VectorWorks:IFCLib:IIFCSupport::ShowManagePsetsDlg: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(6 intermediate revisions by 2 users not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


Shows the Manage Custom Property Sets dialog. From it users can select document Record Formats to be used as custom IFC Property Sets.
Shows the Manage Custom Property Sets dialog. From it users can select document Record Formats to be used as custom IFC Property Sets.
Line 48: Line 48:
Use this function via global pointer gIFC.  
Use this function via global pointer gIFC.  


[[File:ManageCustomPsets.JPG|600×552px|thumbnail|center|Manage Custom Property Sets dialog. Available from: Vectorworks 2012]]
[[File:ManageCustomPsets.JPG|600×552px|thumbnail|center|Manage Custom Property Sets dialog. Image from Vectorworks 2018]]
</remark>  
</remark>  


Line 61: Line 61:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Function available since Vectorworks 2018.
Available from: Vectorworks 2018.
</version>
</version>


</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|ShowManagePsetsDlg]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|ShowManagePsetsDlg]]

Latest revision as of 14:59, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Shows the Manage Custom Property Sets dialog. From it users can select document Record Formats to be used as custom IFC Property Sets.

VCOMError ShowManagePsetsDlg( );

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_NotInitialized Bad VCOM instance used to call the function.
kVCOMError_Failed Routine failed.

Remarks

Use this function via global pointer gIFC.

Error creating thumbnail: Incomplete GD library configuration: Missing function imagecreatefromjpeg
Manage Custom Property Sets dialog. Image from Vectorworks 2018

Version

Available from: Vectorworks 2018.