VCOM:VectorWorks:IFCLib:IIFCSupport::ShowIFCDataForSelection: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 9: Line 9:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


...put some description here...
Displays a dialog from which the user can edit the selected object's IFC data.
</desc>
</desc>


Line 25: Line 25:
hSelectedObject
hSelectedObject
MCObjectHandle
MCObjectHandle
no info.
Selected object's handle.
</line>
</line>
</lineList>
</lineList>
Line 43: Line 43:
kVCOMError_Failed
kVCOMError_Failed
Routine failed.
Routine failed.
</line>
<line>
kVCOMError_NoError
Routine succeeded.
</line>
</line>
</lineList>
</lineList>
Line 50: Line 54:
<remark>
<remark>
Use this function via global pointer gIFC.  
Use this function via global pointer gIFC.  
[[File:IFCDataDlg.png|527x600px|thumbnail|center|IFC Data dialog. The example is from selected object with attached IfcSlab Entity. Image from Vectorworks 2018]]
</remark>
</remark>


Line 58: Line 64:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[VCOM:VectorWorks:Extension:IIFCSupport::ShowObjectIFCDataEditDlg]]
</seeAlso>
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 12.
</version>
</version>



Revision as of 15:53, 8 February 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Displays a dialog from which the user can edit the selected object's IFC data.

VCOMError ShowIFCDataForSelection(
MCObjectHandle hSelectedObject = NULL);

Parameters

hSelectedObject MCObjectHandle Selected object's handle.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.

Remarks

Use this function via global pointer gIFC.

IFC Data dialog. The example is from selected object with attached IfcSlab Entity. Image from Vectorworks 2018

Version

Available from: Vectorworks 12.

See Also

VCOM:VectorWorks:Extension:IIFCSupport::ShowObjectIFCDataEditDlg

[[VCOM:VectorWorks:Extension:IIFCSupport::ShowObjectIFCDataEditDlg]]