VCOM:VectorWorks:IFCLib:IIFCSupport::ShowExportOptions: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
Line 74: Line 74:
</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|ShowExportOptions]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|ShowExportOptions]]

Revision as of 08:02, 5 April 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Displays the "Export IFC Project" dialog wherefrom the user can manage settings for the IFC file and export it.

VCOMError ShowExportOptions(
bool bExportSingleObjects);

Parameters

bExportSingleObjects bool Obsolete flag. Set it to true.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.

Remarks

Use this function via global pointer gIFC.

Export IFC Project dialog. Image from Vectorworks 2018

Version

Available from: Vectorworks 12.