VCOM:VectorWorks:IFCLib:IIFCSupport::ShowExportOptions: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 1: Line 1:
{{LocationMain|category=LocationVCOM|specific=}}
{{LocationMain|category=LocationVCOM|specific=}}
__TOC__
__TOC__
Line 9: Line 10:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


Displays the "Export IFC Project" Dialog wherefrom you can manage some settings for the IFC file and export it.
Displays the "Export IFC Project" dialog wherefrom the user can manage settings for the IFC file and export it.
</desc>
</desc>


Line 25: Line 26:
bExportSingleObjects
bExportSingleObjects
bool
bool
Obsolete flag.
Obsolete flag. Set it to true.
</line>
</line>
</lineList>
</lineList>
Line 62: Line 63:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
<gallery>
[[File:ExportIfcProj.png|527x600px|thumbnail|center|Export IFC Project dialog. Picture from VW2018]]
File:ExportIfcProj.png|Export IFC Project Dialog
</gallery>
</seeAlso>
</seeAlso>



Revision as of 08:58, 2 February 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Displays the "Export IFC Project" dialog wherefrom the user can manage settings for the IFC file and export it.

VCOMError ShowExportOptions(
bool bExportSingleObjects);

Parameters

bExportSingleObjects bool Obsolete flag. Set it to true.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.

See Also

Export IFC Project dialog. Picture from VW2018
[[File:ExportIfcProj.png|527x600px|thumbnail|center|Export IFC Project dialog. Picture from VW2018]]