VCOM:VectorWorks:IFCLib:IIFCSupport::ShowExportOptions: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 8: Line 8:


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Displays the "Export IFC Project" Dialog wherefrom you can manage some settings for the IFC file and export it.
Displays the "Export IFC Project" Dialog wherefrom you can manage some settings for the IFC file and export it.
</desc>
</desc>
Line 42: Line 43:
kVCOMError_Failed
kVCOMError_Failed
Routine failed.
Routine failed.
</line>
<line>
kVCOMError_NoError
kVCOMError_NoError
Routine succeeded.
Routine succeeded.

Revision as of 08:28, 2 February 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Displays the "Export IFC Project" Dialog wherefrom you can manage some settings for the IFC file and export it.

VCOMError ShowExportOptions(
bool bExportSingleObjects);

Parameters

bExportSingleObjects bool Obsolete flag.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.

See Also

File:ExportIfcProj.png|Export IFC Project Dialog