VCOM:VectorWorks:IFCLib:IIFCSupport::ShowExportOptions: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 8: Line 8:


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
 
Displays the "Export IFC Project" Dialog wherefrom you can manage some settings for the IFC file and export it.
...put some description here...
</desc>
</desc>


Line 25: Line 24:
bExportSingleObjects
bExportSingleObjects
bool
bool
no info.
Obsolete flag.
</line>
</line>
</lineList>
</lineList>
Line 43: Line 42:
kVCOMError_Failed
kVCOMError_Failed
Routine failed.
Routine failed.
kVCOMError_NoError
Routine succeeded.
</line>
</line>
</lineList>
</lineList>
Line 49: Line 50:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
Use this function via global pointer gIFC.
</remark>
</remark>


Line 57: Line 59:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
<gallery>
File:ExportIfcProj.png|Export IFC Project Dialog
</gallery>
</seeAlso>
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 12.
</version>
</version>



Revision as of 08:26, 2 February 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport Displays the "Export IFC Project" Dialog wherefrom you can manage some settings for the IFC file and export it.

VCOMError ShowExportOptions(
bool bExportSingleObjects);

Parameters

bExportSingleObjects bool Obsolete flag.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed. kVCOMError_NoError

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.

See Also

File:ExportIfcProj.png|Export IFC Project Dialog