VCOM:VectorWorks:IFCLib:IIFCSupport::ShowExportOptions: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(9 intermediate revisions by 3 users not shown)
Line 1: Line 1:
{{LocationMain|category=LocationVCOM|specific=}}
{{LocationMain|category=LocationVCOM|specific=}}
__TOC__
__TOC__
Line 7: Line 8:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


Displays the "Export IFC Project" Dialog wherefrom you can manage some settings for the IFC file and export it.
Displays the "Export IFC Project" dialog wherefrom the user can manage settings for the IFC file and export it.
</desc>
</desc>


Line 25: Line 26:
bExportSingleObjects
bExportSingleObjects
bool
bool
Obsolete flag.
Obsolete flag. Set it to true.
</line>
</line>
</lineList>
</lineList>
Line 54: Line 55:
<remark>
<remark>
Use this function via global pointer gIFC.
Use this function via global pointer gIFC.
[[File:ExportIfcProj.png|527×600px|thumbnail|center|Export IFC Project dialog. Image from Vectorworks 2018]]
</remark>
</remark>


Line 62: Line 65:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
<gallery>
File:ExportIfcProj.png|Export IFC Project Dialog
</gallery>
</seeAlso>
</seeAlso>


Line 74: Line 74:
</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|ShowExportOptions]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|ShowExportOptions]]

Latest revision as of 14:58, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Displays the "Export IFC Project" dialog wherefrom the user can manage settings for the IFC file and export it.

VCOMError ShowExportOptions(
bool bExportSingleObjects);

Parameters

bExportSingleObjects bool Obsolete flag. Set it to true.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.

Remarks

Use this function via global pointer gIFC.

Export IFC Project dialog. Image from Vectorworks 2018

Version

Available from: Vectorworks 12.