VCOM:VectorWorks:IFCLib:IIFCSupport::SetIFCScheme: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
Line 10: Line 10:
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]


...put some description here...
<font color="green">Use this function via global pointer gIFC.</font>
 
Sets IFC Scheme for the project.
</desc>
</desc>


Line 16: Line 18:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual VCOMErrorVCOM_CALLTYPE SetIFCScheme(EIFCSupportSchema scheme) = 0;
VCOMError SetIFCScheme(EIFCSupportSchema scheme);
</funcDef>
</funcDef>
</def>
</def>
Line 26: Line 28:
scheme
scheme
EIFCSupportSchema
EIFCSupportSchema
no info.
Possible values are <b>kIFCSupportScheme_2x2</b> (IFC 2x3); <b>kIFCSupportScheme_2x3</b> (IFC 2x3) and <b>kIFCSupportScheme_2x4</b> (IFC 4)</line>
</line>
</lineList>
</lineList>
</params>
</params>
Line 38: Line 39:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
kVCOMError_NotInitialized
kVCOMError_Failed
Bad VCOM instance used to call the fuction.
The function failed.
</line>
</line>
<line>
<line>
kVCOMError_Failed
kVCOMError_NoError
Routine failed.
The function succeeded. No Error!
</line>
</line>
</lineList>
</lineList>

Revision as of 14:56, 12 January 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Use this function via global pointer gIFC.

Sets IFC Scheme for the project.

VCOMError SetIFCScheme(
EIFCSupportSchema scheme);

Parameters

scheme EIFCSupportSchema Possible values are kIFCSupportScheme_2x2 (IFC 2x3); kIFCSupportScheme_2x3 (IFC 2x3) and kIFCSupportScheme_2x4 (IFC 4)

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_Failed The function failed.
kVCOMError_NoError The function succeeded. No Error!