VCOM:VectorWorks:IFCLib:IIFCSupport::SetIFCScheme: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
(10 intermediate revisions by 3 users not shown)
Line 1: Line 1:
{{LocationMain|category=LocationVCOM|specific=}}
{{LocationMain|category=LocationVCOM|specific=}}
__TOC__
__TOC__
<vwDoc>
<vwDoc>
Line 8: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Sets IFC Scheme for the project.
</desc>
</desc>


Line 16: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual VCOMErrorVCOM_CALLTYPE SetIFCScheme(EIFCSupportSchema scheme) = 0;
VCOMError SetIFCScheme(EIFCSupportSchema scheme);
</funcDef>
</funcDef>
</def>
</def>
Line 25: Line 24:
<line>
<line>
scheme
scheme
EIFCSupportSchema
[[VCOM:VectorWorks:IFCLib:IFCEnumerations|EIFCSupportSchema]]
no info.
Possible values are <b>kIFCSupportScheme_2x2</b> (IFC 2x2); <b>kIFCSupportScheme_2x3</b> (IFC 2x3) and <b>kIFCSupportScheme_2x4</b> (IFC 4)</line>
</line>
</lineList>
</lineList>
</params>
</params>
Line 38: Line 36:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
kVCOMError_NotInitialized
kVCOMError_Failed
Bad VCOM instance used to call the fuction.
The function failed.
</line>
</line>
<line>
<line>
kVCOMError_Failed
kVCOMError_NoError
Routine failed.
The function succeeded. No Error!
</line>
</line>
</lineList>
</lineList>
Line 50: Line 48:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
Use this function via global pointer gIFC.
</remark>
</remark>


Line 58: Line 57:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<seeAlso>
<seeAlso>
[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_SetIFCScheme|IIFCSupport::IFC_SetIFCScheme]]
</seeAlso>
</seeAlso>


-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 12.
</version>
</version>



Latest revision as of 15:00, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Sets IFC Scheme for the project.

VCOMError SetIFCScheme(
EIFCSupportSchema scheme);

Parameters

scheme EIFCSupportSchema Possible values are kIFCSupportScheme_2x2 (IFC 2x2); kIFCSupportScheme_2x3 (IFC 2x3) and kIFCSupportScheme_2x4 (IFC 4)

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_Failed The function failed.
kVCOMError_NoError The function succeeded. No Error!

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.

See Also

IIFCSupport::IFC_SetIFCScheme

[[VCOM:VectorWorks:IFCLib:IIFCSupport::IFC_SetIFCScheme|IIFCSupport::IFC_SetIFCScheme]]