VCOM:VectorWorks:IFCLib:IIFCSupport::ImportFile

From Vectorworks Developer
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Imports an IFC file.

VCOMError ImportFile(
IFileIdentifier* pFileID,
bool bShowUI);

Parameters

pFileID IFileIdentifier* File identifier where the IFC model is located.
bShowUI bool If set to true, a dialog will appear where you can select which stories and objects to import.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_InvalidArg Wrong file identifier.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.