VCOM:VectorWorks:IFCLib:IIFCSupport::ImportFile: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
Line 80: Line 80:
</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|ImportFile]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|ImportFile]]

Revision as of 08:00, 5 April 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of VCOM:VectorWorks:IFCLib:IIFCSupport

Imports an IFC file.

VCOMError ImportFile(
IFileIdentifier* pFileID,
bool bShowUI);

Parameters

pFileID IFileIdentifier* File identifier where the IFC model is located.
bShowUI bool If set to true, a dialog will appear where you can select which stories and objects to import.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_InvalidArg Wrong file identifier.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.