VCOM:VectorWorks:IFCLib:IIFCSupport::ImportFile: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
No edit summary
 
(3 intermediate revisions by 2 users not shown)
Line 7: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Imports an IFC file.
</desc>
</desc>


Line 25: Line 25:
pFileID
pFileID
IFileIdentifier*
IFileIdentifier*
no info.
File identifier where the IFC model is located.
</line>
</line>
<line>
<line>
bShowUI
bShowUI
bool
bool
no info.
If set to true, a dialog will appear where you can select which stories and objects to import.  
</line>
</line>
</lineList>
</lineList>
Line 44: Line 44:
kVCOMError_NotInitialized
kVCOMError_NotInitialized
Bad VCOM instance used to call the fuction.
Bad VCOM instance used to call the fuction.
</line>
<line>
kVCOMError_InvalidArg
Wrong file identifier.
</line>
</line>
<line>
<line>
kVCOMError_Failed
kVCOMError_Failed
Routine failed.
Routine failed.
</line>
<line>
kVCOMError_NoError
Routine succeeded.
</line>
</line>
</lineList>
</lineList>
Line 54: Line 62:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<remark>
<remark>
Use this function via global pointer gIFC.
</remark>
</remark>


Line 66: Line 75:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 12.
</version>
</version>


</vwDoc>
</vwDoc>


[[Category:VCOM:VectorWorks:Extension:IIFCSupport|ImportFile]]
[[Category:VCOM:VectorWorks:IFCLib:IIFCSupport|ImportFile]]

Latest revision as of 14:58, 19 June 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Imports an IFC file.

VCOMError ImportFile(
IFileIdentifier* pFileID,
bool bShowUI);

Parameters

pFileID IFileIdentifier* File identifier where the IFC model is located.
bShowUI bool If set to true, a dialog will appear where you can select which stories and objects to import.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NotInitialized Bad VCOM instance used to call the fuction.
kVCOMError_InvalidArg Wrong file identifier.
kVCOMError_Failed Routine failed.
kVCOMError_NoError Routine succeeded.

Remarks

Use this function via global pointer gIFC.

Version

Available from: Vectorworks 12.