VCOM:VectorWorks:IFCLib:IIFCSupport::IFC SetPsetProp

From Vectorworks Developer
Revision as of 07:06, 26 July 2018 by NBeshevliev (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search
The printable version is no longer supported and may have rendering errors. Please update your browser bookmarks and please use the default browser print function instead.

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Sets the Object's Property value of a specified Property Set if it's already attached.

VCOMError IFC_SetPsetProp(
MCObjectHandle hObject,
const TXString& strIfcPsetName,
const TXString& strIfcPropName,
const TXString& strIfcPropValue);

Parameters

hObject MCObjectHandle Object's handle.
strIfcPsetName TXString Property Set Name.
strIfcPropName TXString Poperty Name.
strIfcPropValue TXString Value to be set.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Version

Available from: Vectorworks 12.