VCOM:VectorWorks:IFCLib:IIFCSupport::IFC SetPsetProp: Difference between revisions

From Vectorworks Developer
Jump to navigation Jump to search
No edit summary
 
(6 intermediate revisions by 3 users not shown)
Line 1: Line 1:
{{LocationMain|category=LocationVCOM|specific=}}
{{LocationMain|category=LocationVCOM|specific=}}
__TOC__
__TOC__
<vwDoc>
<vwDoc>
Line 8: Line 7:
namespace <code>VectorWorks::IFCLib</code>
namespace <code>VectorWorks::IFCLib</code>


Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport]]
Member of [[VCOM:VectorWorks:IFCLib:IIFCSupport|IIFCSupport]]


...put some description here...
Sets the Object's Property value of a specified Property Set if it's already attached.  
</desc>
</desc>


Line 16: Line 15:
<def>
<def>
<funcDef lang="cpp">
<funcDef lang="cpp">
virtual VCOMErrorVCOM_CALLTYPE IFC_SetPsetProp(MCObjectHandle hObject, const TXString& strIfcPsetName, const TXString& strIfcPropName, const TXString& strIfcPropValue) = 0;
VCOMError IFC_SetPsetProp(MCObjectHandle hObject, const TXString& strIfcPsetName, const TXString& strIfcPropName, const TXString& strIfcPropValue);
</funcDef>
</funcDef>
</def>
</def>
Line 26: Line 25:
hObject
hObject
MCObjectHandle
MCObjectHandle
no info.
Object's handle.
</line>
</line>
<line>
<line>
strIfcPsetName
strIfcPsetName
const [[SDK:TXString]]&
TXString
no info.
Property Set Name.
</line>
</line>
<line>
<line>
strIfcPropName
strIfcPropName
const [[SDK:TXString]]&
TXString
no info.
Poperty Name.
</line>
</line>
<line>
<line>
strIfcPropValue
strIfcPropValue
const [[SDK:TXString]]&
TXString
no info.
Value to be set.
</line>
</line>
</lineList>
</lineList>
Line 53: Line 52:
<lineList ident=1>
<lineList ident=1>
<line>
<line>
kVCOMError_NotInitialized
kVCOMError_NoError
Bad VCOM instance used to call the fuction.
The function succeeded. No Error!
</line>
</line>
<line>
<line>
Line 77: Line 76:
-----------------------------------------------------------------------------------------------------------
-----------------------------------------------------------------------------------------------------------
<version>
<version>
Available from: Vectorworks 12.
</version>
</version>



Latest revision as of 07:06, 26 July 2018

.SDK|SDK ..SDK:Types|SDK Types ..VCOM:VCOM (Vectorworks Component Object Model)|VCOM Basics ..VCOM:Class Reference|VCOM Class Reference

Description

namespace VectorWorks::IFCLib

Member of IIFCSupport

Sets the Object's Property value of a specified Property Set if it's already attached.

VCOMError IFC_SetPsetProp(
MCObjectHandle hObject,
const TXString& strIfcPsetName,
const TXString& strIfcPropName,
const TXString& strIfcPropValue);

Parameters

hObject MCObjectHandle Object's handle.
strIfcPsetName TXString Property Set Name.
strIfcPropName TXString Poperty Name.
strIfcPropValue TXString Value to be set.

Return Value

Uses standard VCOM Error Reporting.

Return value meaning:

kVCOMError_NoError The function succeeded. No Error!
kVCOMError_Failed Routine failed.

Version

Available from: Vectorworks 12.